CVE-2024-33997 moodle: stored XSS risk when editing another user's equation in equation editor
Attackers can inject malicious scripts via the equation editor, potentially stealing user sessions or executing code in other users' browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-33997?
CVE-2024-33997 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 31 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Additional sanitizing was required when opening the equation editor to prevent a stored XSS risk when editing another user's equation.
Weakness: CWE-79
Which versions are affected by CVE-2024-33997?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
1 more packages
moodle Bitnami | All versions | 4.1.10, 4.2.7, 4.3.4 |
Products include Moodle Moodle.
How do I fix CVE-2024-33997?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.10, 4.2.7 or 4.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-33997 being exploited?
There is no known exploitation of CVE-2024-33997 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-33997, GHSA-9qgq-93c7-9hm4, UBUNTU-CVE-2024-33997.