CVE-2024-33998 moodle: stored XSS via user's name on participants page when opening some options
Stored XSS in Moodle allows attackers to execute scripts via user names on the participants page, potentially leading to session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-33998?
CVE-2024-33998 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 31 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Insufficient escaping of participants' names in the participants page table resulted in a stored XSS risk when interacting with some features.
Weakness: CWE-79
Which versions are affected by CVE-2024-33998?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
1 more packages
moodle Bitnami | All versions | 4.1.10, 4.2.7, 4.3.4 |
Products include Moodle Moodle.
How do I fix CVE-2024-33998?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.10, 4.2.7 or 4.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-33998 being exploited?
There is no known exploitation of CVE-2024-33998 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-33998, GHSA-xqhh-253w-4q5f, UBUNTU-CVE-2024-33998.