{"answers":{"affected":"7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-34000 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 4.1.10, 4.2.7 or 4.3.4.","what":"CVE-2024-34000 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 31 May 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-34000 and fix it if it is affected.\n\nWhat it is: CVE-2024-34000 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 31 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-34000 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 4.1.10\n- moodle/moodle (Packagist): affected all versions; fixed in 4.1.10\n- moodle/moodle (Packagist): affected from 4.2.0; fixed in 4.2.7\n- moodle/moodle (Packagist): affected from 4.2.0; fixed in 4.2.7\n- moodle/moodle (Packagist): affected from 4.3.0; fixed in 4.3.4\n- moodle/moodle (Packagist): affected from 4.3.0; fixed in 4.3.4\n- moodle (Bitnami): affected all versions; fixed in 4.1.10, 4.2.7, 4.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34000/ (Markdown: https://insights.sbomify.com/CVE-2024-34000/index.md)","id":"CVE-2024-34000","markdown":"https://insights.sbomify.com/CVE-2024-34000/index.md","name":"CVE-2024-34000","record":{"aliases":["BIT-moodle-2024-34000","GHSA-8qwh-4vwv-7c5m","UBUNTU-CVE-2024-34000"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into the lesson overview report via user ID numbers, potentially compromising user sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ID numbers displayed in the lesson overview report required additional sanitizing to prevent a stored XSS risk.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"moodle: stored XSS in lesson overview report via user ID number","id":"CVE-2024-34000","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2024"},"n_packages":7,"n_references":1,"next":{"headline":"moodle: CSRF risk in admin preset tool management of presets","id":"CVE-2024-34001"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.10","4.2.7","4.3.4"],"introduced":["0","4.2.0","4.3.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2024-34000"},{"ecosystem":"Packagist","fixed":["4.1.10"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-8qwh-4vwv-7c5m"},{"ecosystem":"Packagist","fixed":["4.1.10"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8qwh-4vwv-7c5m"},{"ecosystem":"Packagist","fixed":["4.2.7"],"introduced":["4.2.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-8qwh-4vwv-7c5m"},{"ecosystem":"Packagist","fixed":["4.2.7"],"introduced":["4.2.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8qwh-4vwv-7c5m"},{"ecosystem":"Packagist","fixed":["4.3.4"],"introduced":["4.3.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-8qwh-4vwv-7c5m"},{"ecosystem":"Packagist","fixed":["4.3.4"],"introduced":["4.3.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-8qwh-4vwv-7c5m"}],"prev":{"headline":"moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php","id":"CVE-2024-33999"},"products":["moodle:moodle"],"published":"2024-05-31","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-14","vendors":["moodle"]},"summary":"Attackers can inject malicious scripts into the lesson overview report via user ID numbers, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-34000/"}