CVE-2024-34006 moodle: unsanitized HTML in site log for config_log_created
Attackers can inject malicious HTML into site logs, leading to cross-site scripting attacks against administrators viewing the logs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-34006?
CVE-2024-34006 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 31 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The site log report required additional encoding of event descriptions to ensure any HTML in the content is displayed in plaintext instead of being rendered.
Weakness: CWE-838
Which versions are affected by CVE-2024-34006?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
1 more packages
moodle Bitnami | All versions | 4.1.10, 4.2.7, 4.3.4 |
Products include Moodle Moodle.
How do I fix CVE-2024-34006?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.10, 4.2.7 or 4.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-34006 being exploited?
There is no known exploitation of CVE-2024-34006 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-34006, GHSA-vvh5-7v3m-j3mj, UBUNTU-CVE-2024-34006.