CVE-2024-34008 moodle: CSRF risk in analytics management of models
Attackers can force authenticated administrators to perform unauthorized actions in the analytics model management interface via CSRF.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-34008?
CVE-2024-34008 is a low-severity vulnerability in Moodle Moodle, published on 31 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.
Weakness: CWE-352
Which versions are affected by CVE-2024-34008?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | All versions | 4.1.10 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.2.0 | 4.2.7 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
moodle/moodle Packagist | From 4.3.0 | 4.3.4 |
1 more packages
moodle Bitnami | From 4.0.0 | 4.3.4 |
Products include Moodle Moodle.
How do I fix CVE-2024-34008?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.10, 4.2.7 or 4.3.4.
Is CVE-2024-34008 being exploited?
There is no known exploitation of CVE-2024-34008 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2024-34008, GHSA-68x5-4jg5-gjgg, UBUNTU-CVE-2024-34008.