# CVE-2024-34008: moodle: CSRF risk in analytics management of models

> Attackers can force authenticated administrators to perform unauthorized actions in the analytics model management interface via CSRF.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 May 2024
- **Updated:** 25 Mar 2025
- **Also known as:** BIT-moodle-2024-34008, GHSA-68x5-4jg5-gjgg, UBUNTU-CVE-2024-34008

## What is CVE-2024-34008?

CVE-2024-34008 is a low-severity vulnerability in Moodle Moodle, published on 31 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-34008?

7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | 4.1.10 |
| `moodle/moodle` | Packagist | All versions | 4.1.10 |
| `moodle/moodle` | Packagist | From 4.2.0 | 4.2.7 |
| `moodle/moodle` | Packagist | From 4.2.0 | 4.2.7 |
| `moodle/moodle` | Packagist | From 4.3.0 | 4.3.4 |
| `moodle/moodle` | Packagist | From 4.3.0 | 4.3.4 |
| `moodle` | Bitnami | From 4.0.0 | 4.3.4 |

Products: Moodle Moodle.

## How do I fix CVE-2024-34008?

Upgrade moodle/moodle to a fixed version for your release line: 4.1.10, 4.2.7 or 4.3.4.

## Is CVE-2024-34008 being exploited?

There is no known exploitation of CVE-2024-34008 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34008 and fix it if it is affected.

What it is: CVE-2024-34008 is a low-severity vulnerability in Moodle Moodle, published on 31 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34008 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.10
- moodle/moodle (Packagist): affected all versions; fixed in 4.1.10
- moodle/moodle (Packagist): affected from 4.2.0; fixed in 4.2.7
- moodle/moodle (Packagist): affected from 4.2.0; fixed in 4.2.7
- moodle/moodle (Packagist): affected from 4.3.0; fixed in 4.3.4
- moodle/moodle (Packagist): affected from 4.3.0; fixed in 4.3.4
- moodle (Bitnami): affected from 4.0.0; fixed in 4.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34008/ (Markdown: https://insights.sbomify.com/CVE-2024-34008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34008
- OSV: https://osv.dev/vulnerability/CVE-2024-34008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34008/
Summaries are generated and may contain mistakes; the official description above is the record.
