{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34020 exists.","fix":"Apply the vendor's patch.","what":"CVE-2024-34020 is a medium-severity memory corruption vulnerability in n/a, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34020 and fix it if it is affected.\n\nWhat it is: CVE-2024-34020 is a medium-severity memory corruption vulnerability in n/a, published on 29 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34020 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34020/ (Markdown: https://insights.sbomify.com/CVE-2024-34020/index.md)","id":"CVE-2024-34020","markdown":"https://insights.sbomify.com/CVE-2024-34020/index.md","name":"CVE-2024-34020","record":{"aliases":["GHSA-fvj9-whqh-93ff","openSUSE-SU-2024:13915-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"hcode library","requires_auth":"none","summary":"A stack-based buffer overflow in the hcode library allows attackers to execute arbitrary code or cause a denial of service.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"A stack-based buffer overflow was found in the putSDN() function of mail.c in hcode through 2.1.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2024-34020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"File upload in WMC-2LX-B","id":"CVE-2024-34021"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.1-680.1"],"introduced":["0"],"last_affected":[],"package":"hcode","purl":"pkg:rpm/opensuse/hcode\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13915-1"}],"prev":{"headline":"Privilege escalation in Acronis Snap Deploy","id":"CVE-2024-34019"},"products":["n/a"],"published":"2024-04-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["n/a"]},"summary":"A stack-based buffer overflow in the hcode library allows attackers to execute arbitrary code or cause a denial of service.","url":"https://insights.sbomify.com/CVE-2024-34020/"}