{"answers":{"affected":"2 open source packages ship an affected version, including dolibarr/dolibarr.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34051 exists.","fix":"Upgrade dolibarr/dolibarr to 19.0.2 or later.","what":"CVE-2024-34051 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34051 and fix it if it is affected.\n\nWhat it is: CVE-2024-34051 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Jun 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34051 exists.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 19.0.2\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 19.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34051/ (Markdown: https://insights.sbomify.com/CVE-2024-34051/index.md)","id":"CVE-2024-34051","markdown":"https://insights.sbomify.com/CVE-2024-34051/index.md","name":"CVE-2024-34051","record":{"aliases":["GHSA-hv2j-6654-x74q","UBUNTU-CVE-2024-34051"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via the facid parameter in Dolibarr, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":4.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Reflected Cross-site scripting (XSS) vulnerability located in htdocs/compta/paiement/card.php of Dolibarr before 19.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into the facid parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Reflected Cross-Site Scripting (XSS) in Dolibarr","id":"CVE-2024-34051","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2024-34055"},"packages":[{"ecosystem":"Packagist","fixed":["19.0.2"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-hv2j-6654-x74q"},{"ecosystem":"Packagist","fixed":["19.0.2"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-hv2j-6654-x74q"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2024-34050"},"products":["n/a"],"published":"2024-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the facid parameter in Dolibarr, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2024-34051/"}