# CVE-2024-3406: WP Prayer <= 2.0.9 - Email Settings Update via CSRF

> Attackers can trick logged-in admins into changing email settings via CSRF, requiring an upgrade to the WP Prayer plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 May 2024
- **Updated:** 9 Jan 2026
- **Also known as:** GHSA-x989-xh8p-mqvh

## What is CVE-2024-3406?

CVE-2024-3406 is a high-severity vulnerability in Unknown WP Prayer, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The WP Prayer WordPress plugin through 2.0.9 does not have CSRF check in place when updating its email settings, which could allow attackers to make a logged in admin change them via a CSRF attack

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-3406?

It affects 1 product.


Products: Goprayer Wp Prayer.

## How do I fix CVE-2024-3406?

No fix has been published for CVE-2024-3406 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-3406 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3406 exists.

## Other vulnerabilities in Unknown WP Prayer

- [CVE-2024-3405](https://insights.sbomify.com/CVE-2024-3405/): WP Prayer <= 2.0.9 - Settings Update via CSRF (high 7.6)
- [CVE-2023-25705](https://insights.sbomify.com/CVE-2023-25705/): WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS) (medium 5.9)
- [CVE-2021-24313](https://insights.sbomify.com/CVE-2021-24313/): WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS) (medium 5.4)
- [CVE-2024-3407](https://insights.sbomify.com/CVE-2024-3407/): WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF (medium 5.3)
- [CVE-2021-4412](https://insights.sbomify.com/CVE-2021-4412/): WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3406 and fix it if it is affected.

What it is: CVE-2024-3406 is a high-severity vulnerability in Unknown WP Prayer, published on 15 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3406 exists.

Affected product: Unknown WP Prayer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3406/ (Markdown: https://insights.sbomify.com/CVE-2024-3406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3406
- OSV: https://osv.dev/vulnerability/CVE-2024-3406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3406/
Summaries are generated and may contain mistakes; the official description above is the record.
