{"answers":{"affected":"3 open source packages ship an affected version, including tqdm.","exploited":"There is no known exploitation of CVE-2024-34062 in the wild and no public exploit code.","fix":"Upgrade tqdm to 4.66.3 or later.","what":"CVE-2024-34062 is a medium-severity vulnerability in tqdm, published on 3 May 2024."},"fix_prompt":"Check this codebase for CVE-2024-34062 and fix it if it is affected.\n\nWhat it is: CVE-2024-34062 is a medium-severity vulnerability in tqdm, published on 3 May 2024. \nExploitation: There is no known exploitation of CVE-2024-34062 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tqdm (PyPI): affected from 4.4.0; fixed in 4.66.3\n- tqdm (PyPI): affected from 4.4.0; fixed in 4.66.3\n- tqdm (PyPI): affected from 4.4.0; fixed in 4.66.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34062/ (Markdown: https://insights.sbomify.com/CVE-2024-34062/index.md)","id":"CVE-2024-34062","markdown":"https://insights.sbomify.com/CVE-2024-34062/index.md","name":"CVE-2024-34062","record":{"aliases":["AZL-40285","AZL-40307","CLSA-2025-1758672759","DEBIAN-CVE-2024-34062","GHSA-g7vv-2v7x-gj9p","MGASA-2024-0299","OESA-2024-1554","OESA-2024-1555","OESA-2024-1658","OESA-2024-1659","PYSEC-2026-1976","SUSE-SU-2024:1872-1","UBUNTU-CVE-2024-34062","USN-7216-1","openSUSE-SU-2024:13939-1"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"tqdm is an open source progress bar for Python and CLI. Any optional non-boolean CLI arguments (e.g. `--delim`, `--buf-size`, `--manpath`) are passed through python's `eval`, allowing arbitrary code execution. This issue is only locally exploitable and had been addressed in release version 4.66.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["PyPI","SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS","SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS","SUSE:Linux Enterprise Module for Public Cloud 15 SP4","SUSE:Linux Enterprise Module for Python 3 15 SP5","SUSE:Linux Enterprise Module for Python 3 15 SP6","SUSE:Linux Enterprise Server 15 SP4-LTSS","SUSE:Linux Enterprise Server for SAP Applications 15 SP4","openSUSE:Leap 15.5","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tqdm CLI arguments injection attack","id":"CVE-2024-34062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2024"},"n_packages":12,"n_references":5,"next":{"headline":"Degraded secret zeroization capabilities in vodozemac","id":"CVE-2024-34063"},"packages":[{"ecosystem":"PyPI","fixed":["4.66.3"],"introduced":["4.4.0"],"last_affected":[],"package":"tqdm","purl":null,"source":"GHSA-g7vv-2v7x-gj9p"},{"ecosystem":"PyPI","fixed":["4.66.3"],"introduced":["4.4.0"],"last_affected":[],"package":"tqdm","purl":"pkg:pypi/tqdm","source":"GHSA-g7vv-2v7x-gj9p"},{"ecosystem":"PyPI","fixed":["4.66.3"],"introduced":["4.4.0"],"last_affected":[],"package":"tqdm","purl":"pkg:pypi/tqdm","source":"PYSEC-2026-1976"},{"ecosystem":"SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20High%20Performance%20Computing%2015%20SP4-ESPOS","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20High%20Performance%20Computing%2015%20SP4-LTSS","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP4","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP4","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Python 3 15 SP5","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Python%203%2015%20SP5","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Python 3 15 SP6","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Python%203%2015%20SP6","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"SUSE:Linux Enterprise Server 15 SP4-LTSS","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20Server%2015%20SP4-LTSS","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 15 SP4","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/suse/python-tqdm\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2015%20SP4","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/opensuse/python-tqdm\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2024:1872-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["4.66.4-150400.9.12.1"],"introduced":["0"],"last_affected":[],"package":"python-tqdm","purl":"pkg:rpm/opensuse/python-tqdm\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:1872-1"}],"prev":{"headline":"Reflected cross site scripting in changedetection.io","id":"CVE-2024-34061"},"products":["tqdm"],"published":"2024-05-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["tqdm"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-34062/"}