# CVE-2024-34065: @strapi/plugin-users-permissions leaks 3rd party authentication tokens and authentication bypass

> Unauthenticated attackers can bypass authentication and steal third-party tokens via open redirect and token leakage in Strapi's users permissions plugin.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-wrvh-rcmr-9qfc

## What is CVE-2024-34065?

CVE-2024-34065 is a high-severity authentication bypass vulnerability in strapi, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Strapi is an open-source content management system. By combining two vulnerabilities (an `Open Redirect` and `session token sent as URL query parameter`) in @strapi/plugin-users-permissions before version 4.24.2, is its possible of an unauthenticated attacker to bypass authentication mechanisms and retrieve the 3rd party tokens. The attack requires user interaction (one click). Unauthenticated attackers can leverage two vulnerabilities to obtain an 3rd party token and the bypass authentication of Strapi apps. Users should upgrade @strapi/plugin-users-permissions to version 4.24.2 to receive a patch.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2024-34065?

2 open source packages ship an affected version, including @strapi/plugin-users-permissions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-users-permissions` | npm | All versions | 4.24.2 |
| `@strapi/plugin-users-permissions` | npm | All versions | 4.24.2 |

Products: Strapi Strapi.

## How do I fix CVE-2024-34065?

Upgrade @strapi/plugin-users-permissions to 4.24.2 or later.

## Is CVE-2024-34065 being exploited?

There is no known exploitation of CVE-2024-34065 in the wild and no public exploit code.

## Other vulnerabilities in strapi

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34065 and fix it if it is affected.

What it is: CVE-2024-34065 is a high-severity authentication bypass vulnerability in strapi, published on 12 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34065 in the wild and no public exploit code.

Affected packages and fixed versions:
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.24.2
- @strapi/plugin-users-permissions (npm): affected all versions; fixed in 4.24.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34065/ (Markdown: https://insights.sbomify.com/CVE-2024-34065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34065
- OSV: https://osv.dev/vulnerability/CVE-2024-34065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34065/
Summaries are generated and may contain mistakes; the official description above is the record.
