# CVE-2024-34066: Arbitrary File Write/Read in Pterodactyl wings

> An attacker with a leaked Wings token can read and write arbitrary files on the associated node, compromising server integrity and confidentiality.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-gqmf-jqgv-v8fw, GO-2024-2814

## What is CVE-2024-34066?

CVE-2024-34066 is a high-severity path traversal vulnerability in pterodactyl wings, published on 3 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Pterodactyl wings is the server control plane for Pterodactyl Panel. If the Wings token is leaked either by viewing the node configuration or posting it accidentally somewhere, an attacker can use it to gain arbitrary file write and read access on the node the token is associated to. This issue has been addressed in version 1.11.12 and users are advised to upgrade. Users unable to upgrade may enable the `ignore_panel_config_updates` option as a workaround.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2024-34066?

3 open source packages ship an affected version, including github.com/pterodactyl/wings. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pterodactyl/wings` | Go | All versions | 1.11.12 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.11.12 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.11.12 |

Products: Pterodactyl Wings.

## How do I fix CVE-2024-34066?

Upgrade github.com/pterodactyl/wings to 1.11.12 or later.

## Is CVE-2024-34066 being exploited?

There is no known exploitation of CVE-2024-34066 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl wings

- [CVE-2024-27102](https://insights.sbomify.com/CVE-2024-27102/): Improper isolation of server file access in github.com/pterodactyl/wings (critical 10.0)
- [CVE-2023-25168](https://insights.sbomify.com/CVE-2023-25168/): Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings (critical 9.6)
- [CVE-2023-32080](https://insights.sbomify.com/CVE-2023-32080/): Wings vulnerable to escape to host from installation container (critical 9.1)
- [CVE-2023-25152](https://insights.sbomify.com/CVE-2023-25152/): Symbolic Link (Symlink) Following in github.com/pterodactyl/wings (high 8.4)
- [CVE-2025-69199](https://insights.sbomify.com/CVE-2025-69199/): Pterodactyl websocket endpoints have no visible rate limits or monitoring, allowing for DOS attacks (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34066 and fix it if it is affected.

What it is: CVE-2024-34066 is a high-severity path traversal vulnerability in pterodactyl wings, published on 3 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34066 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.11.12
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.11.12
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.11.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34066/ (Markdown: https://insights.sbomify.com/CVE-2024-34066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34066
- OSV: https://osv.dev/vulnerability/CVE-2024-34066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34066/
Summaries are generated and may contain mistakes; the official description above is the record.
