# CVE-2024-34067: Multiple cross site scripting (XSS) vulnerabilities in the admin area of Pterodactyl panel

> Attackers can inject malicious scripts via egg imports or Wings access to hijack administrator accounts in the Pterodactyl panel.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-384w-wffr-x63q

## What is CVE-2024-34067?

CVE-2024-34067 is a medium-severity cross-site scripting vulnerability in pterodactyl panel, published on 3 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pterodactyl is a free, open-source game server management panel built with PHP, React, and Go. Importing a malicious egg or gaining access to wings instance could lead to cross site scripting (XSS) on the panel, which could be used to gain an administrator account on the panel. Specifically, the following things are impacted: Egg Docker images and Egg variables: Name, Environment variable, Default value, Description, Validation rules. Additionally, certain fields would reflect malicious input, but it would require the user knowingly entering such input to have an impact. To iterate, this would require an administrator to perform actions and can't be triggered by a normal panel user. This issue has has been addressed in version 1.11.6 and users are advised to upgrade. No workaround is available other than updating to the latest version of the panel.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34067?

2 open source packages ship an affected version, including pterodactyl/panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pterodactyl/panel` | Packagist | All versions | 1.11.6 |
| `pterodactyl/panel` | Packagist | All versions | 1.11.6 |

Products: Pterodactyl Panel.

## How do I fix CVE-2024-34067?

Upgrade pterodactyl/panel to 1.11.6 or later.

## Is CVE-2024-34067 being exploited?

There is no known exploitation of CVE-2024-34067 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl panel

- [CVE-2026-26016](https://insights.sbomify.com/CVE-2026-26016/): Pterodactyl Panel Allows Cross-Node Server Configuration Disclosure via Remote API Missing Authorization (critical 9.2)
- [CVE-2021-41129](https://insights.sbomify.com/CVE-2021-41129/): Authentication bypass in Pterodactyl (high 8.1)
- [CVE-2025-68954](https://insights.sbomify.com/CVE-2025-68954/): Pterodactyl does not revoke SFTP access when server is deleted or permissions reduced (high 7.5)
- [CVE-2019-1020002](https://insights.sbomify.com/CVE-2019-1020002/): Pterodactyl vulnerable to 2FA Sniffing (high 7.5)
- [CVE-2025-69197](https://insights.sbomify.com/CVE-2025-69197/): Pterodactyl TOTPs can be reused during validity window (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34067 and fix it if it is affected.

What it is: CVE-2024-34067 is a medium-severity cross-site scripting vulnerability in pterodactyl panel, published on 3 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34067 in the wild and no public exploit code.

Affected packages and fixed versions:
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.11.6
- pterodactyl/panel (Packagist): affected all versions; fixed in 1.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34067/ (Markdown: https://insights.sbomify.com/CVE-2024-34067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34067
- OSV: https://osv.dev/vulnerability/CVE-2024-34067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34067/
Summaries are generated and may contain mistakes; the official description above is the record.
