# CVE-2024-34068: Server-side Request Forgery during remote file pull in Pterodactyl wings

> Authenticated users can bypass access controls to perform Server-Side Request Forgery, accessing internal network resources via the remote file pull endpoint.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qq22-jj8x-4wwv, GO-2024-2815

## What is CVE-2024-34068?

CVE-2024-34068 is a medium-severity server-side request forgery vulnerability in pterodactyl wings, published on 3 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pterodactyl wings is the server control plane for Pterodactyl Panel. An authenticated user who has access to a game server is able to bypass the previously implemented access control (GHSA-6rg3-8h8x-5xfv) that prevents accessing internal endpoints of the node hosting Wings in the pull endpoint. This would allow malicious users to potentially access resources on local networks that would otherwise be inaccessible. This issue has been addressed in version 1.11.2 and users are advised to upgrade. Users unable to upgrade may enable the `api.disable_remote_download` option as a workaround.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-34068?

3 open source packages ship an affected version, including github.com/pterodactyl/wings. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pterodactyl/wings` | Go | All versions | 1.11.12 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.11.12 |
| `github.com/pterodactyl/wings` | Go | All versions | 1.11.12 |

Products: Pterodactyl Wings.

## How do I fix CVE-2024-34068?

Upgrade github.com/pterodactyl/wings to 1.11.12 or later.

## Is CVE-2024-34068 being exploited?

There is no known exploitation of CVE-2024-34068 in the wild and no public exploit code.

## Other vulnerabilities in pterodactyl wings

- [CVE-2024-27102](https://insights.sbomify.com/CVE-2024-27102/): Improper isolation of server file access in github.com/pterodactyl/wings (critical 10.0)
- [CVE-2023-25168](https://insights.sbomify.com/CVE-2023-25168/): Symbolic Link (Symlink) Following allowing the deletion of files and directories on the host system in wings (critical 9.6)
- [CVE-2023-32080](https://insights.sbomify.com/CVE-2023-32080/): Wings vulnerable to escape to host from installation container (critical 9.1)
- [CVE-2024-34066](https://insights.sbomify.com/CVE-2024-34066/): Arbitrary File Write/Read in Pterodactyl wings (high 8.5)
- [CVE-2023-25152](https://insights.sbomify.com/CVE-2023-25152/): Symbolic Link (Symlink) Following in github.com/pterodactyl/wings (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34068 and fix it if it is affected.

What it is: CVE-2024-34068 is a medium-severity server-side request forgery vulnerability in pterodactyl wings, published on 3 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34068 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.11.12
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.11.12
- github.com/pterodactyl/wings (Go): affected all versions; fixed in 1.11.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34068/ (Markdown: https://insights.sbomify.com/CVE-2024-34068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34068
- OSV: https://osv.dev/vulnerability/CVE-2024-34068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34068/
Summaries are generated and may contain mistakes; the official description above is the record.
