# CVE-2024-3407: WP Prayer <= 2.0.9 - Arbitrary Prayer Deletion via CSRF

> Attackers can trick logged-in users into deleting arbitrary prayers via CSRF in the WP Prayer WordPress plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-53j6-rqp4-4h6m

## What is CVE-2024-3407?

CVE-2024-3407 is a medium-severity vulnerability in Unknown WP Prayer, published on 15 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The WP Prayer WordPress plugin through 2.0.9 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2024-3407?

It affects 1 product.


Products: Goprayer Wp Prayer.

## How do I fix CVE-2024-3407?

No fix has been published for CVE-2024-3407 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-3407 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3407 exists.

## Other vulnerabilities in Unknown WP Prayer

- [CVE-2024-3406](https://insights.sbomify.com/CVE-2024-3406/): WP Prayer <= 2.0.9 - Email Settings Update via CSRF (high 8.8)
- [CVE-2024-3405](https://insights.sbomify.com/CVE-2024-3405/): WP Prayer <= 2.0.9 - Settings Update via CSRF (high 7.6)
- [CVE-2023-25705](https://insights.sbomify.com/CVE-2023-25705/): WordPress WP Prayer Plugin <= 1.9.6 is vulnerable to Cross Site Scripting (XSS) (medium 5.9)
- [CVE-2021-24313](https://insights.sbomify.com/CVE-2021-24313/): WP Prayer < 1.6.2 - Authenticated Stored Cross-Site Scripting (XSS) (medium 5.4)
- [CVE-2021-4412](https://insights.sbomify.com/CVE-2021-4412/): WP Prayer <= 1.6.5 - Cross-Site Request Forgery Bypass (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3407 and fix it if it is affected.

What it is: CVE-2024-3407 is a medium-severity vulnerability in Unknown WP Prayer, published on 15 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3407 exists.

Affected product: Unknown WP Prayer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3407/ (Markdown: https://insights.sbomify.com/CVE-2024-3407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3407
- OSV: https://osv.dev/vulnerability/CVE-2024-3407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3407/
Summaries are generated and may contain mistakes; the official description above is the record.
