{"answers":{"affected":"2 open source packages ship an affected version, including froxlor/froxlor.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34070 exists.","fix":"Upgrade froxlor/froxlor to 2.1.9 or later.","what":"CVE-2024-34070 is a critical cross-site scripting vulnerability in Froxlor, published on 10 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34070 and fix it if it is affected.\n\nWhat it is: CVE-2024-34070 is a critical cross-site scripting vulnerability in Froxlor, published on 10 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34070 exists.\n\nAffected packages and fixed versions:\n- froxlor/froxlor (Packagist): affected all versions; fixed in 2.1.9\n- froxlor/froxlor (Packagist): affected all versions; fixed in 2.1.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34070/ (Markdown: https://insights.sbomify.com/CVE-2024-34070/index.md)","id":"CVE-2024-34070","markdown":"https://insights.sbomify.com/CVE-2024-34070/index.md","name":"CVE-2024-34070","record":{"aliases":["GHSA-x525-54hf-xr53"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Server administration software","requires_auth":"none","summary":"An unauthenticated attacker can inject malicious scripts via login attempts, leading to administrator account takeover and full application control.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.7,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Froxlor is open source server administration software. Prior to 2.1.9, a Stored Blind Cross-Site Scripting (XSS) vulnerability was identified in the Failed Login Attempts Logging Feature of the Froxlor Application. An unauthenticated User can inject malicious scripts in the loginname parameter on the Login attempt, which will then be executed when viewed by the Administrator in the System Logs.  By exploiting this vulnerability, the attacker can perform various malicious actions such as forcing the Administrator to execute actions without their knowledge or consent. For instance, the attacker can force the Administrator to add a new administrator controlled by the attacker, thereby giving the attacker full control over the application. This vulnerability is fixed in 2.1.9.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-05-18","github_poc":2,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-06-05T22:28:12Z","kind":"github_poc","ref":"https://github.com/Okymi-X/CVE-2024-34070","stars":2,"title":null},{"date":"2026-05-18T17:23:39Z","kind":"github_poc","ref":"https://github.com/Akira07210/Exploit-CVE-2024-34070","stars":0,"title":"Script exploit the CVE-2024-32019. Credit to froxlor for the vuln."}],"tier":"weaponised"},"has_fix":true,"headline":"Froxlor Vulnerable to Blind XSS Leading to Froxlor Application Compromise","id":"CVE-2024-34070","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Open Redirect Bypass Protection","id":"CVE-2024-34071"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.9"],"introduced":["0"],"last_affected":[],"package":"froxlor/froxlor","purl":null,"source":"GHSA-x525-54hf-xr53"},{"ecosystem":"Packagist","fixed":["2.1.9"],"introduced":["0"],"last_affected":[],"package":"froxlor/froxlor","purl":"pkg:composer/froxlor/froxlor","source":"GHSA-x525-54hf-xr53"}],"prev":{"headline":"Werkzeug's improper usage of a pathname and improper CSRF protection results in the remote command execution","id":"CVE-2024-34069"},"products":["Froxlor"],"published":"2024-05-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["froxlor"]},"summary":"An unauthenticated attacker can inject malicious scripts via login attempts, leading to administrator account takeover and full application control.","url":"https://insights.sbomify.com/CVE-2024-34070/"}