{"answers":{"affected":"3 open source packages ship an affected version, including sagemaker.","exploited":"There is no known exploitation of CVE-2024-34072 in the wild and no public exploit code.","fix":"Upgrade sagemaker to 2.218.0 or later.","what":"CVE-2024-34072 is a high-severity unsafe deserialization vulnerability in aws sagemaker-python-sdk, published on 3 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34072 and fix it if it is affected.\n\nWhat it is: CVE-2024-34072 is a high-severity unsafe deserialization vulnerability in aws sagemaker-python-sdk, published on 3 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-34072 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sagemaker (PyPI): affected all versions; fixed in 2.218.0\n- sagemaker (PyPI): affected all versions; fixed in 2.218.0\n- sagemaker (PyPI): affected all versions; fixed in 2.218.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34072/ (Markdown: https://insights.sbomify.com/CVE-2024-34072/index.md)","id":"CVE-2024-34072","markdown":"https://insights.sbomify.com/CVE-2024-34072/index.md","name":"CVE-2024-34072","record":{"aliases":["GHSA-wjvx-jhpj-r54r","PYSEC-2026-1889"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"SageMaker Python SDK","requires_auth":"none","summary":"An attacker can achieve remote code execution or denial of service by passing malicious pickled numpy object arrays to the NumpyDeserializer module.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. The sagemaker.base_deserializers.NumpyDeserializer module before v2.218.0 allows potentially unsafe deserialization when untrusted data is passed as pickled object arrays. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. Users are advised to upgrade to version 2.218.0. Users unable to upgrade should not pass pickled numpy object arrays which originated from an untrusted source, or that could have been tampered with. Only pass pickled numpy object arrays from trusted sources.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deserialization of Untrusted Data in sagemaker-python-sdk","id":"CVE-2024-34072","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Command Injection in sagemaker-python-sdk","id":"CVE-2024-34073"},"packages":[{"ecosystem":"PyPI","fixed":["2.218.0"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":null,"source":"GHSA-wjvx-jhpj-r54r"},{"ecosystem":"PyPI","fixed":["2.218.0"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":"pkg:pypi/sagemaker","source":"GHSA-wjvx-jhpj-r54r"},{"ecosystem":"PyPI","fixed":["2.218.0"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":"pkg:pypi/sagemaker","source":"PYSEC-2026-1889"}],"prev":{"headline":"Open Redirect Bypass Protection","id":"CVE-2024-34071"},"products":["sagemaker-python-sdk"],"published":"2024-05-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["aws"]},"summary":"An attacker can achieve remote code execution or denial of service by passing malicious pickled numpy object arrays to the NumpyDeserializer module.","url":"https://insights.sbomify.com/CVE-2024-34072/"}