{"answers":{"affected":"3 open source packages ship an affected version, including sagemaker.","exploited":"There is no known exploitation of CVE-2024-34073 in the wild and no public exploit code.","fix":"Upgrade sagemaker to 2.214.3 or later.","what":"CVE-2024-34073 is a high-severity command injection vulnerability in aws sagemaker-python-sdk, published on 3 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34073 and fix it if it is affected.\n\nWhat it is: CVE-2024-34073 is a high-severity command injection vulnerability in aws sagemaker-python-sdk, published on 3 May 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-34073 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sagemaker (PyPI): affected all versions; fixed in 2.214.3\n- sagemaker (PyPI): affected all versions; fixed in 2.214.3\n- sagemaker (PyPI): affected all versions; fixed in 2.214.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34073/ (Markdown: https://insights.sbomify.com/CVE-2024-34073/index.md)","id":"CVE-2024-34073","markdown":"https://insights.sbomify.com/CVE-2024-34073/index.md","name":"CVE-2024-34073","record":{"aliases":["GHSA-7pc3-pr3q-58vg","PYSEC-2026-1887"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"SageMaker Python SDK","requires_auth":"none","summary":"Command injection in sagemaker-python-sdk allows remote code execution and denial of service if the requirements_path parameter is improperly controlled.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. In affected versions the capture_dependencies function in `sagemaker.serve.save_retrive.version_1_0_0.save.utils` module allows for potentially unsafe Operating System (OS) Command Injection if inappropriate command is passed as the “requirements_path” parameter. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. This issue has been addressed in version 2.214.3. Users are advised to upgrade. Users unable to upgrade should not override the “requirements_path” parameter of capture_dependencies function in `sagemaker.serve.save_retrive.version_1_0_0.save.utils`, and instead use the default value.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in sagemaker-python-sdk","id":"CVE-2024-34073","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Frappe vuilnerable to an open redirect on login page","id":"CVE-2024-34074"},"packages":[{"ecosystem":"PyPI","fixed":["2.214.3"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":null,"source":"GHSA-7pc3-pr3q-58vg"},{"ecosystem":"PyPI","fixed":["2.214.3"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":"pkg:pypi/sagemaker","source":"GHSA-7pc3-pr3q-58vg"},{"ecosystem":"PyPI","fixed":["2.214.3"],"introduced":["0"],"last_affected":[],"package":"sagemaker","purl":"pkg:pypi/sagemaker","source":"PYSEC-2026-1887"}],"prev":{"headline":"Deserialization of Untrusted Data in sagemaker-python-sdk","id":"CVE-2024-34072"},"products":["sagemaker-python-sdk"],"published":"2024-05-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["aws"]},"summary":"Command injection in sagemaker-python-sdk allows remote code execution and denial of service if the requirements_path parameter is improperly controlled.","url":"https://insights.sbomify.com/CVE-2024-34073/"}