# CVE-2024-34077: MantisBT user account takeover in the signup/reset password process

> Attackers can take over user accounts by brute-forcing user IDs during the password reset window, gaining full access to sensitive data and functionalities.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-93x3-m7pw-ppqm

## What is CVE-2024-34077?

CVE-2024-34077 is a high-severity authentication bypass vulnerability in Mantisbt Mantisbt, published on 13 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MantisBT (Mantis Bug Tracker) is an open source issue tracker. Insufficient access control in the registration and password reset process allows an attacker to reset another user's password and takeover their account, if the victim has an incomplete request pending. The exploit is only possible while the verification token is valid, i.e for 5 minutes after the confirmation URL sent by e-mail has been opened, and the user did not complete the process by updating their password. A brute-force attack calling account_update.php with increasing user IDs is possible. A successful takeover would grant the attacker full access to the compromised account, including sensitive information and functionalities associated with the account, the extent of which depends on its privileges and the data it has access to. Version 2.26.2 contains a patch for the issue. As a workaround, one may mitigate the risk by reducing the verification token's validity (change the value of the `TOKEN_EXPIRY_AUTHENTICATED` constant in `constants_inc.php`).

Weakness: CWE-620 (Unverified Password Change), CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2024-34077?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.26.2 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.26.2 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2024-34077?

Upgrade mantisbt/mantisbt to 2.26.2 or later.

## Is CVE-2024-34077 being exploited?

There is no known exploitation of CVE-2024-34077 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34077 and fix it if it is affected.

What it is: CVE-2024-34077 is a high-severity authentication bypass vulnerability in Mantisbt Mantisbt, published on 13 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34077 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.26.2
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34077/ (Markdown: https://insights.sbomify.com/CVE-2024-34077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34077
- OSV: https://osv.dev/vulnerability/CVE-2024-34077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34077/
Summaries are generated and may contain mistakes; the official description above is the record.
