# CVE-2024-34078: html-sanitizer allows arbitrary HTML present after sanitization because of unicode normalization

> An attacker can inject arbitrary HTML via unicode normalization bypass in the html-sanitizer library, potentially leading to XSS.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 May 2024
- **Updated:** 26 Aug 2024
- **Also known as:** DEBIAN-CVE-2024-34078, DLA-3856-1, GHSA-wvhx-q427-fgh3, PYSEC-2026-1455, UBUNTU-CVE-2024-34078

## What is CVE-2024-34078?

CVE-2024-34078 is a medium-severity cross-site scripting vulnerability in matthiask html-sanitizer, published on 6 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

html-sanitizer is an allowlist-based HTML cleaner. If using `keep_typographic_whitespace=False` (which is the default), the sanitizer normalizes unicode to the NFKC form at the end. Some unicode characters normalize to chevrons; this allows specially crafted HTML to escape sanitization. The problem has been fixed in 2.4.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34078?

3 open source packages ship an affected version, including html-sanitizer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `html-sanitizer` | PyPI | All versions | 2.4.2 |
| `html-sanitizer` | PyPI | All versions | 2.4.2 |
| `html-sanitizer` | PyPI | All versions | 2.4.2 |

## How do I fix CVE-2024-34078?

Upgrade html-sanitizer to 2.4.2 or later.

## Is CVE-2024-34078 being exploited?

There is no known exploitation of CVE-2024-34078 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34078 and fix it if it is affected.

What it is: CVE-2024-34078 is a medium-severity cross-site scripting vulnerability in matthiask html-sanitizer, published on 6 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34078 in the wild and no public exploit code.

Affected packages and fixed versions:
- html-sanitizer (PyPI): affected all versions; fixed in 2.4.2
- html-sanitizer (PyPI): affected all versions; fixed in 2.4.2
- html-sanitizer (PyPI): affected all versions; fixed in 2.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34078/ (Markdown: https://insights.sbomify.com/CVE-2024-34078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34078
- OSV: https://osv.dev/vulnerability/CVE-2024-34078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34078/
Summaries are generated and may contain mistakes; the official description above is the record.
