# CVE-2024-34079: octo-sts allows unauthenticated attackers to cause unbounded CPU and memory usage

> Unauthenticated attackers can cause unbounded CPU and memory usage in octo-sts, potentially leading to a denial of service.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-75r6-6jg8-pfcq, GO-2024-2833

## What is CVE-2024-34079?

CVE-2024-34079 is a low-severity denial of service vulnerability in octo-sts app, published on 10 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

octo-sts is a GitHub App that acts like a Security Token Service (STS) for the Github API. This vulnerability can spike the resource utilization of the STS service, and combined with a significant traffic volume could potentially lead to a denial of service. This vulnerability is fixed in 0.1.0

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-34079?

3 open source packages ship an affected version, including github.com/octo-sts/app.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/octo-sts/app` | Go | All versions | 0.1.0 |
| `github.com/octo-sts/app` | Go | All versions | 0.1.0 |
| `github.com/octo-sts/app` | Go | All versions | 0.1.0 |

## How do I fix CVE-2024-34079?

Upgrade github.com/octo-sts/app to 0.1.0 or later.

## Is CVE-2024-34079 being exploited?

There is no known exploitation of CVE-2024-34079 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34079 and fix it if it is affected.

What it is: CVE-2024-34079 is a low-severity denial of service vulnerability in octo-sts app, published on 10 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34079 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/octo-sts/app (Go): affected all versions; fixed in 0.1.0
- github.com/octo-sts/app (Go): affected all versions; fixed in 0.1.0
- github.com/octo-sts/app (Go): affected all versions; fixed in 0.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34079/ (Markdown: https://insights.sbomify.com/CVE-2024-34079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34079
- OSV: https://osv.dev/vulnerability/CVE-2024-34079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34079/
Summaries are generated and may contain mistakes; the official description above is the record.
