# CVE-2024-34080: MantisBT Vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

> An attacker can view sensitive metadata about inaccessible notes, including author names and timestamps, by exploiting cross-issue note references in MantisBT.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-99jc-wqmr-ff2q

## What is CVE-2024-34080?

CVE-2024-34080 is a medium-severity vulnerability in Mantisbt Mantisbt, published on 13 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MantisBT (Mantis Bug Tracker) is an open source issue tracker. If an issue references a note that belongs to another issue that the user doesn't have access to, then it gets hyperlinked. Clicking on the link gives an access denied error as expected, yet some information remains available via the link, link label, and tooltip. This can result in disclosure of the existence of the note, the note author name, the note creation timestamp, and the issue id the note belongs to. Version 2.26.2 contains a patch for the issue. No known workarounds are available.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-34080?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.26.2 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.26.2 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2024-34080?

Upgrade mantisbt/mantisbt to 2.26.2 or later.

## Is CVE-2024-34080 being exploited?

There is no known exploitation of CVE-2024-34080 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34080 and fix it if it is affected.

What it is: CVE-2024-34080 is a medium-severity vulnerability in Mantisbt Mantisbt, published on 13 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34080 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.26.2
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.26.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34080/ (Markdown: https://insights.sbomify.com/CVE-2024-34080/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34080
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34080
- OSV: https://osv.dev/vulnerability/CVE-2024-34080

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34080/
Summaries are generated and may contain mistakes; the official description above is the record.
