# CVE-2024-34082: Grav Arbitrary File Read to Account Takeover

> Low-privilege users can read sensitive server files via Twig syntax, enabling password hash extraction and full account takeover of other users.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-f8v5-jmfh-pr69

## What is CVE-2024-34082?

CVE-2024-34082 is a high-severity vulnerability in Getgrav Grav, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to version 1.7.46, a low privilege user account with page edit privilege can read any server files using Twig Syntax. This includes Grav user account files - `/grav/user/accounts/*.yaml`. This file stores hashed user password, 2FA secret, and the password reset token. This can allow an adversary to compromise any registered account and read any file in the web server by resetting a password for a user to get access to the password reset token from the file or by cracking the hashed password. A low privileged user may also perform a full account takeover of other registered users including Administrators. Version 1.7.46 contains a patch.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-34082?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.46 |
| `getgrav/grav` | Packagist | All versions | 1.7.46 |

Products: Getgrav Grav.

## How do I fix CVE-2024-34082?

Upgrade getgrav/grav to 1.7.46 or later.

## Is CVE-2024-34082 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34082 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34082 and fix it if it is affected.

What it is: CVE-2024-34082 is a high-severity vulnerability in Getgrav Grav, published on 15 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34082 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.46
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.46

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34082/ (Markdown: https://insights.sbomify.com/CVE-2024-34082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34082
- OSV: https://osv.dev/vulnerability/CVE-2024-34082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34082/
Summaries are generated and may contain mistakes; the official description above is the record.
