# CVE-2024-34084: Minder's Github Webhook Handler vulnerable to denial of service from un-validated requests

> An attacker can crash the Minder controlplane by sending unvalidated HTTP requests to the GitHub webhook handler, denying service to other users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-9c5w-9q3f-3hv7, GO-2024-2821

## What is CVE-2024-34084?

CVE-2024-34084 is a high-severity denial of service vulnerability in stacklok minder, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Minder's `HandleGithubWebhook` is susceptible to a denial of service attack from an untrusted HTTP request. The vulnerability exists before the request has been validated, and as such the request is still untrusted at the point of failure. This allows an attacker with the ability to send requests to `HandleGithubWebhook` to crash the Minder controlplane and deny other users from using it. This vulnerability is fixed in 0.0.48.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-34084?

3 open source packages ship an affected version, including github.com/stacklok/minder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/stacklok/minder` | Go | All versions | 0.0.48 |
| `github.com/stacklok/minder` | Go | All versions | 0.0.48 |
| `github.com/stacklok/minder` | Go | All versions | 0.0.48 |

## How do I fix CVE-2024-34084?

Upgrade github.com/stacklok/minder to 0.0.48 or later.

## Is CVE-2024-34084 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34084 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34084 and fix it if it is affected.

What it is: CVE-2024-34084 is a high-severity denial of service vulnerability in stacklok minder, published on 7 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34084 exists.

Affected packages and fixed versions:
- github.com/stacklok/minder (Go): affected all versions; fixed in 0.0.48
- github.com/stacklok/minder (Go): affected all versions; fixed in 0.0.48
- github.com/stacklok/minder (Go): affected all versions; fixed in 0.0.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34084/ (Markdown: https://insights.sbomify.com/CVE-2024-34084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34084
- OSV: https://osv.dev/vulnerability/CVE-2024-34084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34084/
Summaries are generated and may contain mistakes; the official description above is the record.
