# CVE-2024-34273: njwt Prototype Pollution vulnerability

> Prototype pollution in the njwt library allows attackers to manipulate object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-3hvj-2783-34x2

## What is CVE-2024-34273?

CVE-2024-34273 is a medium-severity vulnerability in n/a, published on 16 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

njwt up to v0.4.0 was discovered to contain a prototype pollution in the Parser.prototype.parse method.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-34273?

2 open source packages ship an affected version, including njwt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `njwt` | npm | All versions | 2.0.1 |
| `njwt` | npm | All versions | 2.0.1 |

## How do I fix CVE-2024-34273?

Upgrade njwt to 2.0.1 or later.

## Is CVE-2024-34273 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34273 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34273 and fix it if it is affected.

What it is: CVE-2024-34273 is a medium-severity vulnerability in n/a, published on 16 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34273 exists.

Affected packages and fixed versions:
- njwt (npm): affected all versions; fixed in 2.0.1
- njwt (npm): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34273/ (Markdown: https://insights.sbomify.com/CVE-2024-34273/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34273
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34273
- OSV: https://osv.dev/vulnerability/CVE-2024-34273

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34273/
Summaries are generated and may contain mistakes; the official description above is the record.
