CVE-2024-34341 The Trix Editor Contains an Arbitrary Code Execution Vulnerability
Attackers can execute arbitrary code by tricking users into pasting malicious markup into the Trix rich text editor.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-34341?
CVE-2024-34341 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 7 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.
Weakness: CWE-79
Which versions are affected by CVE-2024-34341?
8 open source packages ship an affected version, including trix and actiontext.
| Package | Affected | Fixed in |
|---|---|---|
trix npm | From 0.9.0 | 1.3.2 |
trix npm | From 0.9.0 | 1.3.2 |
trix npm | From 2.0.0 | 2.1.1 |
trix npm | From 2.0.0 | 2.1.1 |
actiontext RubyGems | From 7.0.0.alpha1 | 7.0.8.3 |
actiontext RubyGems | From 7.0.0.alpha1 | 7.0.8.3 |
2 more packages
actiontext RubyGems | From 7.1.0.beta1 | 7.1.3.3 |
actiontext RubyGems | From 7.1.0.beta1 | 7.1.3.3 |
Linux distribution packages (1)
rubygem-actiontext-7.0 openSUSE:Tumbleweed | All versions | 7.0.8.4-1.1 |
How do I fix CVE-2024-34341?
Upgrade trix to a fixed version for your release line: 1.3.2 or 2.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-34341 being exploited?
There is no known exploitation of CVE-2024-34341 in the wild and no public exploit code.
Sources
Also known as GHSA-qjqp-xr96-cj99, openSUSE-SU-2024:14068-1.