{"answers":{"affected":"8 open source packages ship an affected version, including trix and actiontext.","exploited":"There is no known exploitation of CVE-2024-34341 in the wild and no public exploit code.","fix":"Upgrade trix to a fixed version for your release line: 1.3.2 or 2.1.1.","what":"CVE-2024-34341 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 7 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34341 and fix it if it is affected.\n\nWhat it is: CVE-2024-34341 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 7 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-34341 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trix (npm): affected from 0.9.0; fixed in 1.3.2\n- trix (npm): affected from 0.9.0; fixed in 1.3.2\n- trix (npm): affected from 2.0.0; fixed in 2.1.1\n- trix (npm): affected from 2.0.0; fixed in 2.1.1\n- actiontext (RubyGems): affected from 7.0.0.alpha1; fixed in 7.0.8.3\n- actiontext (RubyGems): affected from 7.0.0.alpha1; fixed in 7.0.8.3\n- actiontext (RubyGems): affected from 7.1.0.beta1; fixed in 7.1.3.3\n- actiontext (RubyGems): affected from 7.1.0.beta1; fixed in 7.1.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34341/ (Markdown: https://insights.sbomify.com/CVE-2024-34341/index.md)","id":"CVE-2024-34341","markdown":"https://insights.sbomify.com/CVE-2024-34341/index.md","name":"CVE-2024-34341","record":{"aliases":["GHSA-qjqp-xr96-cj99","openSUSE-SU-2024:14068-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Trix rich text editor","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into pasting malicious markup into the Trix rich text editor.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.","ecosystems":["RubyGems","npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"The Trix Editor Contains an Arbitrary Code Execution Vulnerability","id":"CVE-2024-34341","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":9,"n_references":6,"next":{"headline":"react-pdf's PDF.js vulnerable to arbitrary JavaScript execution upon opening a malicious PDF","id":"CVE-2024-34342"},"packages":[{"ecosystem":"RubyGems","fixed":["7.0.8.3"],"introduced":["7.0.0.alpha1"],"last_affected":[],"package":"actiontext","purl":null,"source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"RubyGems","fixed":["7.0.8.3"],"introduced":["7.0.0.alpha1"],"last_affected":[],"package":"actiontext","purl":"pkg:gem/actiontext","source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"RubyGems","fixed":["7.1.3.3"],"introduced":["7.1.0.beta1"],"last_affected":[],"package":"actiontext","purl":null,"source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"RubyGems","fixed":["7.1.3.3"],"introduced":["7.1.0.beta1"],"last_affected":[],"package":"actiontext","purl":"pkg:gem/actiontext","source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0.9.0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"npm","fixed":["1.3.2"],"introduced":["0.9.0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"npm","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-qjqp-xr96-cj99"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["7.0.8.4-1.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-actiontext-7.0","purl":"pkg:rpm/opensuse/rubygem-actiontext-7.0\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14068-1"}],"prev":{"headline":"Authentication Bypass when using using older password hashes","id":"CVE-2024-34340"},"products":["trix"],"published":"2024-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["basecamp"]},"summary":"Attackers can execute arbitrary code by tricking users into pasting malicious markup into the Trix rich text editor.","url":"https://insights.sbomify.com/CVE-2024-34341/"}