# CVE-2024-34341: The Trix Editor Contains an Arbitrary Code Execution Vulnerability

> Attackers can execute arbitrary code by tricking users into pasting malicious markup into the Trix rich text editor.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qjqp-xr96-cj99, openSUSE-SU-2024:14068-1

## What is CVE-2024-34341?

CVE-2024-34341 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 7 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34341?

8 open source packages ship an affected version, including trix and actiontext.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trix` | npm | From 0.9.0 | 1.3.2 |
| `trix` | npm | From 0.9.0 | 1.3.2 |
| `trix` | npm | From 2.0.0 | 2.1.1 |
| `trix` | npm | From 2.0.0 | 2.1.1 |
| `actiontext` | RubyGems | From 7.0.0.alpha1 | 7.0.8.3 |
| `actiontext` | RubyGems | From 7.0.0.alpha1 | 7.0.8.3 |
| `actiontext` | RubyGems | From 7.1.0.beta1 | 7.1.3.3 |
| `actiontext` | RubyGems | From 7.1.0.beta1 | 7.1.3.3 |
| `rubygem-actiontext-7.0` | openSUSE:Tumbleweed | All versions | 7.0.8.4-1.1 |

## How do I fix CVE-2024-34341?

Upgrade trix to a fixed version for your release line: 1.3.2 or 2.1.1.

## Is CVE-2024-34341 being exploited?

There is no known exploitation of CVE-2024-34341 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34341 and fix it if it is affected.

What it is: CVE-2024-34341 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 7 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34341 in the wild and no public exploit code.

Affected packages and fixed versions:
- trix (npm): affected from 0.9.0; fixed in 1.3.2
- trix (npm): affected from 0.9.0; fixed in 1.3.2
- trix (npm): affected from 2.0.0; fixed in 2.1.1
- trix (npm): affected from 2.0.0; fixed in 2.1.1
- actiontext (RubyGems): affected from 7.0.0.alpha1; fixed in 7.0.8.3
- actiontext (RubyGems): affected from 7.0.0.alpha1; fixed in 7.0.8.3
- actiontext (RubyGems): affected from 7.1.0.beta1; fixed in 7.1.3.3
- actiontext (RubyGems): affected from 7.1.0.beta1; fixed in 7.1.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34341/ (Markdown: https://insights.sbomify.com/CVE-2024-34341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34341
- OSV: https://osv.dev/vulnerability/CVE-2024-34341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34341/
Summaries are generated and may contain mistakes; the official description above is the record.
