{"answers":{"affected":"2 open source packages ship an affected version, including deno. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-34346 in the wild and no public exploit code.","fix":"Upgrade deno to 1.43.1 or later.","what":"CVE-2024-34346 is a high-severity vulnerability in denoland deno, published on 7 May 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-34346 and fix it if it is affected.\n\nWhat it is: CVE-2024-34346 is a high-severity vulnerability in denoland deno, published on 7 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-34346 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected all versions; fixed in 1.43.1\n- deno (crates.io): affected all versions; fixed in 1.43.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34346/ (Markdown: https://insights.sbomify.com/CVE-2024-34346/index.md)","id":"CVE-2024-34346","markdown":"https://insights.sbomify.com/CVE-2024-34346/index.md","name":"CVE-2024-34346","record":{"aliases":["GHSA-23rx-c3g5-hv9w","JLSEC-2026-107"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Deno runtime","requires_auth":"high_privilege","summary":"Attackers can escalate privileges by reading or writing privileged system files when filesystem access is granted, bypassing intended sandbox restrictions.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. The Deno sandbox may be unexpectedly weakened by allowing file read/write access to privileged files in various locations on Unix and Windows platforms. For example, reading `/proc/self/environ` may provide access equivalent to `--allow-env`, and writing `/proc/self/mem` may provide access equivalent to `--allow-all`. Users who grant read and write access to the entire filesystem may not realize that these access to these files may have additional, unintended consequences. The documentation did not reflect that this practice should be undertaken to increase the strength of the security sandbox. Users who run code with `--allow-read` or `--allow-write` may unexpectedly end up granting additional permissions via file-system operations. Deno 1.43 and above require explicit `--allow-all` access to read or write `/etc`, `/dev` on unix platform (as well as `/proc` and `/sys` on linux platforms), and any path starting with `\\\\` on Windows.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deno contains a permission escalation via open of privileged files with missing `--deny` flag","id":"CVE-2024-34346","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"@hoppscotch/cli affected by Sandbox Escape in @hoppscotch/js-sandbox leads to RCE","id":"CVE-2024-34347"},"packages":[{"ecosystem":"crates.io","fixed":["1.43.1"],"introduced":["0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-23rx-c3g5-hv9w"},{"ecosystem":"crates.io","fixed":["1.43.1"],"introduced":["0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-23rx-c3g5-hv9w"}],"prev":{"headline":"@cyclonedx/cyclonedx-library Improper Restriction of XML External Entity Reference vulnerability","id":"CVE-2024-34345"},"products":["deno"],"published":"2024-05-07","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["denoland"]},"summary":"Attackers can escalate privileges by reading or writing privileged system files when filesystem access is granted, bypassing intended sandbox restrictions.","url":"https://insights.sbomify.com/CVE-2024-34346/"}