# CVE-2024-34346: Deno contains a permission escalation via open of privileged files with missing `--deny` flag

> Attackers can escalate privileges by reading or writing privileged system files when filesystem access is granted, bypassing intended sandbox restrictions.

- **Severity:** High 8.5 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-23rx-c3g5-hv9w, JLSEC-2026-107

## What is CVE-2024-34346?

CVE-2024-34346 is a high-severity vulnerability in denoland deno, published on 7 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. The Deno sandbox may be unexpectedly weakened by allowing file read/write access to privileged files in various locations on Unix and Windows platforms. For example, reading `/proc/self/environ` may provide access equivalent to `--allow-env`, and writing `/proc/self/mem` may provide access equivalent to `--allow-all`. Users who grant read and write access to the entire filesystem may not realize that these access to these files may have additional, unintended consequences. The documentation did not reflect that this practice should be undertaken to increase the strength of the security sandbox. Users who run code with `--allow-read` or `--allow-write` may unexpectedly end up granting additional permissions via file-system operations. Deno 1.43 and above require explicit `--allow-all` access to read or write `/etc`, `/dev` on unix platform (as well as `/proc` and `/sys` on linux platforms), and any path starting with `\\` on Windows.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-34346?

2 open source packages ship an affected version, including deno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | All versions | 1.43.1 |
| `deno` | crates.io | All versions | 1.43.1 |

Products: Deno Deno.

## How do I fix CVE-2024-34346?

Upgrade deno to 1.43.1 or later.

## Is CVE-2024-34346 being exploited?

There is no known exploitation of CVE-2024-34346 in the wild and no public exploit code.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34346 and fix it if it is affected.

What it is: CVE-2024-34346 is a high-severity vulnerability in denoland deno, published on 7 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34346 in the wild and no public exploit code.

Affected packages and fixed versions:
- deno (crates.io): affected all versions; fixed in 1.43.1
- deno (crates.io): affected all versions; fixed in 1.43.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34346/ (Markdown: https://insights.sbomify.com/CVE-2024-34346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34346
- OSV: https://osv.dev/vulnerability/CVE-2024-34346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34346/
Summaries are generated and may contain mistakes; the official description above is the record.
