{"answers":{"affected":"2 open source packages ship an affected version, including @hoppscotch/cli.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34347 exists.","fix":"Upgrade @hoppscotch/cli to 0.8.0 or later.","what":"CVE-2024-34347 is a high-severity code injection vulnerability in hoppscotch, published on 8 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34347 and fix it if it is affected.\n\nWhat it is: CVE-2024-34347 is a high-severity code injection vulnerability in hoppscotch, published on 8 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34347 exists.\n\nAffected packages and fixed versions:\n- @hoppscotch/cli (npm): affected from 0.5.0; fixed in 0.8.0\n- @hoppscotch/cli (npm): affected from 0.5.0; fixed in 0.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34347/ (Markdown: https://insights.sbomify.com/CVE-2024-34347/index.md)","id":"CVE-2024-34347","markdown":"https://insights.sbomify.com/CVE-2024-34347/index.md","name":"CVE-2024-34347","record":{"aliases":["GHSA-qmmm-73r2-f8xr"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Hoppscotch CLI","requires_auth":"none","summary":"Attackers can execute arbitrary code by escaping the JavaScript sandbox in Hoppscotch CLI via crafted pre-request scripts.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"@hoppscotch/cli is a CLI to run Hoppscotch Test Scripts in CI environments. Prior to 0.8.0, the @hoppscotch/js-sandbox package provides a Javascript sandbox that uses the Node.js vm module. However, the vm module is not safe for sandboxing untrusted Javascript code. This is because code inside the vm context can break out if it can get a hold of any reference to an object created outside of the vm. In the case of @hoppscotch/js-sandbox, multiple references to external objects are passed into the vm context to allow pre-request scripts interactions with environment variables and more. But this also allows the pre-request script to escape the sandbox. This vulnerability is fixed in 0.8.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@hoppscotch/cli affected by Sandbox Escape in @hoppscotch/js-sandbox leads to RCE","id":"CVE-2024-34347","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Sylius potentially vulnerable to Cross Site Scripting via \"Name\" field (Taxons, Products, Options, Variants) in Admin Panel","id":"CVE-2024-34349"},"packages":[{"ecosystem":"npm","fixed":["0.8.0"],"introduced":["0.5.0"],"last_affected":[],"package":"@hoppscotch/cli","purl":null,"source":"GHSA-qmmm-73r2-f8xr"},{"ecosystem":"npm","fixed":["0.8.0"],"introduced":["0.5.0"],"last_affected":[],"package":"@hoppscotch/cli","purl":"pkg:npm/%40hoppscotch/cli","source":"GHSA-qmmm-73r2-f8xr"}],"prev":{"headline":"Deno contains a permission escalation via open of privileged files with missing `--deny` flag","id":"CVE-2024-34346"},"products":["hoppscotch"],"published":"2024-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-10","vendors":["hoppscotch"]},"summary":"Attackers can execute arbitrary code by escaping the JavaScript sandbox in Hoppscotch CLI via crafted pre-request scripts.","url":"https://insights.sbomify.com/CVE-2024-34347/"}