# CVE-2024-34347: @hoppscotch/cli affected by Sandbox Escape in @hoppscotch/js-sandbox leads to RCE

> Attackers can execute arbitrary code by escaping the JavaScript sandbox in Hoppscotch CLI via crafted pre-request scripts.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 May 2024
- **Updated:** 10 Jun 2025
- **Also known as:** GHSA-qmmm-73r2-f8xr

## What is CVE-2024-34347?

CVE-2024-34347 is a high-severity code injection vulnerability in hoppscotch, published on 8 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

@hoppscotch/cli is a CLI to run Hoppscotch Test Scripts in CI environments. Prior to 0.8.0, the @hoppscotch/js-sandbox package provides a Javascript sandbox that uses the Node.js vm module. However, the vm module is not safe for sandboxing untrusted Javascript code. This is because code inside the vm context can break out if it can get a hold of any reference to an object created outside of the vm. In the case of @hoppscotch/js-sandbox, multiple references to external objects are passed into the vm context to allow pre-request scripts interactions with environment variables and more. But this also allows the pre-request script to escape the sandbox. This vulnerability is fixed in 0.8.0.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-34347?

2 open source packages ship an affected version, including @hoppscotch/cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hoppscotch/cli` | npm | From 0.5.0 | 0.8.0 |
| `@hoppscotch/cli` | npm | From 0.5.0 | 0.8.0 |

## How do I fix CVE-2024-34347?

Upgrade @hoppscotch/cli to 0.8.0 or later.

## Is CVE-2024-34347 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34347 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34347 and fix it if it is affected.

What it is: CVE-2024-34347 is a high-severity code injection vulnerability in hoppscotch, published on 8 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34347 exists.

Affected packages and fixed versions:
- @hoppscotch/cli (npm): affected from 0.5.0; fixed in 0.8.0
- @hoppscotch/cli (npm): affected from 0.5.0; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34347/ (Markdown: https://insights.sbomify.com/CVE-2024-34347/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34347
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34347
- OSV: https://osv.dev/vulnerability/CVE-2024-34347

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34347/
Summaries are generated and may contain mistakes; the official description above is the record.
