# CVE-2024-34349: Sylius potentially vulnerable to Cross Site Scripting via "Name" field (Taxons, Products, Options, Variants) in Admin Panel

> Attackers can inject JavaScript via Name fields in the Sylius admin panel, potentially leading to code execution or account takeover.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-v2f9-rv6w-vw8r

## What is CVE-2024-34349?

CVE-2024-34349 is a medium-severity cross-site scripting vulnerability in Sylius, published on 10 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Sylius is an open source eCommerce platform. Prior to 1.12.16 and 1.13.1, there is a possibility to execute javascript code in the Admin panel. In order to perform an XSS attack input a script into Name field in which of the resources: Taxons, Products, Product Options or Product Variants. The code will be executed while using an autocomplete field with one of the listed entities in the Admin Panel. Also for the taxons in the category tree on the product form.The issue is fixed in versions: 1.12.16, 1.13.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34349?

10 open source packages ship an affected version, including sylius/sylius.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | All versions | 1.9.12 |
| `sylius/sylius` | Packagist | All versions | 1.9.12 |
| `sylius/sylius` | Packagist | From 1.10.0-alpha.1 | 1.10.16 |
| `sylius/sylius` | Packagist | From 1.10.0-alpha.1 | 1.10.16 |
| `sylius/sylius` | Packagist | From 1.11.0-alpha.1 | 1.11.17 |
| `sylius/sylius` | Packagist | From 1.11.0-alpha.1 | 1.11.17 |
| `sylius/sylius` | Packagist | From 1.12.0-alpha.1 | 1.12.16 |
| `sylius/sylius` | Packagist | From 1.12.0-alpha.1 | 1.12.16 |
| `sylius/sylius` | Packagist | From 1.13.0-alpha.1 | 1.13.1 |
| `sylius/sylius` | Packagist | From 1.13.0-alpha.1 | 1.13.1 |

## How do I fix CVE-2024-34349?

Upgrade sylius/sylius to a fixed version for your release line: 1.9.12, 1.10.16, 1.11.17 or 1.12.16.

## Is CVE-2024-34349 being exploited?

There is no known exploitation of CVE-2024-34349 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34349 and fix it if it is affected.

What it is: CVE-2024-34349 is a medium-severity cross-site scripting vulnerability in Sylius, published on 10 May 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-34349 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.12
- sylius/sylius (Packagist): affected all versions; fixed in 1.9.12
- sylius/sylius (Packagist): affected from 1.10.0-alpha.1; fixed in 1.10.16
- sylius/sylius (Packagist): affected from 1.10.0-alpha.1; fixed in 1.10.16
- sylius/sylius (Packagist): affected from 1.11.0-alpha.1; fixed in 1.11.17
- sylius/sylius (Packagist): affected from 1.11.0-alpha.1; fixed in 1.11.17
- sylius/sylius (Packagist): affected from 1.12.0-alpha.1; fixed in 1.12.16
- sylius/sylius (Packagist): affected from 1.12.0-alpha.1; fixed in 1.12.16
- sylius/sylius (Packagist): affected from 1.13.0-alpha.1; fixed in 1.13.1
- sylius/sylius (Packagist): affected from 1.13.0-alpha.1; fixed in 1.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34349/ (Markdown: https://insights.sbomify.com/CVE-2024-34349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34349
- OSV: https://osv.dev/vulnerability/CVE-2024-34349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34349/
Summaries are generated and may contain mistakes; the official description above is the record.
