# CVE-2024-34350: Next.js Vulnerable to HTTP Request Smuggling

> Attackers can poison response queues via HTTP request smuggling in Next.js apps using rewrites, potentially exposing or modifying data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-77r5-gw3j-2mpf, ROOT-APP-NPM-CVE-2024-34350

## What is CVE-2024-34350?

CVE-2024-34350 is a high-severity vulnerability in Vercel Next.js, published on 9 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework that can provide building blocks to create web applications. Prior to 13.5.1, an inconsistent interpretation of a crafted HTTP request meant that requests are treated as both a single request, and two separate requests by Next.js, leading to desynchronized responses. This led to a response queue poisoning vulnerability in the affected Next.js versions. For a request to be exploitable, the affected route also had to be making use of the [rewrites](https://nextjs.org/docs/app/api-reference/next-config-js/rewrites) feature in Next.js. The vulnerability is resolved in Next.js `13.5.1` and newer.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-34350?

2 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.4.0 | 13.5.1 |
| `next` | npm | From 13.4.0 | 13.5.1 |

Products: Vercel Next.js.

## How do I fix CVE-2024-34350?

Upgrade next to 13.5.1 or later.

## Is CVE-2024-34350 being exploited?

There is no known exploitation of CVE-2024-34350 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34350 and fix it if it is affected.

What it is: CVE-2024-34350 is a high-severity vulnerability in Vercel Next.js, published on 9 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34350 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.4.0; fixed in 13.5.1
- next (npm): affected from 13.4.0; fixed in 13.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34350/ (Markdown: https://insights.sbomify.com/CVE-2024-34350/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34350
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34350
- OSV: https://osv.dev/vulnerability/CVE-2024-34350

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34350/
Summaries are generated and may contain mistakes; the official description above is the record.
