CVE-2024-34355 TYPO3 vulnerable to an HTML Injection in the History Module

Low 3.5 Published Updated

Authenticated backend users can inject malicious HTML into the TYPO3 history module, potentially altering displayed content despite CSP protections.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-34355?

CVE-2024-34355 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 14 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

TYPO3 is an enterprise content management system. Starting in version 13.0.0 and prior to version 13.1.1, the history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account. TYPO3 version 13.1.1 fixes the problem described.

Weakness: CWE-79, CWE-116

Which versions are affected by CVE-2024-34355?

2 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.

PackageAffectedFixed in
typo3/cms-core PackagistFrom 13.0.013.1.1
typo3/cms-core PackagistFrom 13.0.013.1.1

Products include Typo3 Typo3.

How do I fix CVE-2024-34355?

Upgrade typo3/cms-core to 13.1.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-34355 being exploited?

There is no known exploitation of CVE-2024-34355 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-xjwx-78x7-q6jc.

Is CVE-2024-34355 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free