CVE-2024-34356 TYPO3 vulnerable to Cross-Site Scripting in the Form Manager Module
An authenticated backend user can execute arbitrary scripts in the TYPO3 Form Manager module, potentially compromising other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-34356?
CVE-2024-34356 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 14 May 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TYPO3 is an enterprise content management system. Starting in version 9.0.0 and prior to versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, and 13.1.1, the form manager backend module is vulnerable to cross-site scripting. Exploiting this vulnerability requires a valid backend user account with access to the form module. TYPO3 versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, and 13.1.1 fix the problem described.
Weakness: CWE-79
Which versions are affected by CVE-2024-34356?
10 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
typo3/cms-core Packagist | From 10.0.0 | 10.4.45 |
typo3/cms-core Packagist | From 10.0.0 | 10.4.45 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.37 |
typo3/cms-core Packagist | From 11.0.0 | 11.5.37 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.15 |
typo3/cms-core Packagist | From 12.0.0 | 12.4.15 |
4 more packages
typo3/cms-core Packagist | From 13.0.0 | 13.1.1 |
typo3/cms-core Packagist | From 13.0.0 | 13.1.1 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.48 |
typo3/cms-core Packagist | From 9.0.0 | 9.5.48 |
Products include Typo3 Typo3.
How do I fix CVE-2024-34356?
Upgrade typo3/cms-core to a fixed version for your release line: 10.4.45, 11.5.37, 12.4.15 or 13.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-34356 being exploited?
There is no known exploitation of CVE-2024-34356 in the wild and no public exploit code.
Other vulnerabilities in Typo3 Typo3
- CVE-2009-0258 Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection
- CVE-2011-3583 Typo3 SQL injection due to faulty prepared statements
- CVE-2011-4628 Typo3 Authentication Bypass
- CVE-2023-24814 Persisted Cross-Site Scripting in Frontend Rendering in typo3
- CVE-2021-41113 Cross-Site-Request-Forgery in Backend URI Handling in Typo3
Sources
Also known as GHSA-v6mw-h7w6-59w3.