# CVE-2024-34358: TYPO3 vulnerable to an Uncontrolled Resource Consumption in the ShowImageController

> Attackers can trigger excessive server-side thumbnail generation via unvalidated parameters, causing resource exhaustion and denial of service in TYPO3.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-36g8-62qv-5957

## What is CVE-2024-34358?

CVE-2024-34358 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 14 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TYPO3 is an enterprise content management system. Starting in version 9.0.0 and prior to versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, and 13.1.1, the `ShowImageController` (`_eID tx_cms_showpic_`) lacks a cryptographic HMAC-signature on the `frame` HTTP query parameter (e.g. `/index.php?eID=tx_cms_showpic?file=3&...&frame=12345`). This allows adversaries to instruct the system to produce an arbitrary number of thumbnail images on the server side. TYPO3 versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, 13.1.1 fix the problem described.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-347 (Improper Verification of Cryptographic Signature), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-34358?

10 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.45 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.45 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.37 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.37 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.15 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.15 |
| `typo3/cms-core` | Packagist | From 13.0.0 | 13.1.1 |
| `typo3/cms-core` | Packagist | From 13.0.0 | 13.1.1 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.48 |
| `typo3/cms-core` | Packagist | From 9.0.0 | 9.5.48 |

Products: Typo3 Typo3.

## How do I fix CVE-2024-34358?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.45, 11.5.37, 12.4.15 or 13.1.1.

## Is CVE-2024-34358 being exploited?

There is no known exploitation of CVE-2024-34358 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34358 and fix it if it is affected.

What it is: CVE-2024-34358 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 14 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34358 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.45
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.45
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.37
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.37
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.15
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.15
- typo3/cms-core (Packagist): affected from 13.0.0; fixed in 13.1.1
- typo3/cms-core (Packagist): affected from 13.0.0; fixed in 13.1.1
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.48
- typo3/cms-core (Packagist): affected from 9.0.0; fixed in 9.5.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34358/ (Markdown: https://insights.sbomify.com/CVE-2024-34358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34358
- OSV: https://osv.dev/vulnerability/CVE-2024-34358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34358/
Summaries are generated and may contain mistakes; the official description above is the record.
