# CVE-2024-34448: Ghost allows CSV Injection during member CSV export


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-ghost-2024-34448, GHSA-xgwh-cgv9-783v, ROOT-APP-NPM-CVE-2024-34448

## What is CVE-2024-34448?

CVE-2024-34448 is a high-severity vulnerability in n/a, published on 22 May 2024. 

### Official description

Ghost before 5.82.0 allows CSV Injection during a member CSV export.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-34448?

3 open source packages ship an affected version, including @tryghost/members-csv and ghost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tryghost/members-csv` | npm | All versions | 5.82.0 |
| `@tryghost/members-csv` | npm | All versions | 5.82.0 |
| `ghost` | Bitnami | All versions | 5.82.0 |

Products: Ghost Ghost.

## How do I fix CVE-2024-34448?

Upgrade @tryghost/members-csv to 5.82.0 or later.

## Is CVE-2024-34448 being exploited?

There is no known exploitation of CVE-2024-34448 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34448 and fix it if it is affected.

What it is: CVE-2024-34448 is a high-severity vulnerability in n/a, published on 22 May 2024. 
Exploitation: There is no known exploitation of CVE-2024-34448 in the wild and no public exploit code.

Affected packages and fixed versions:
- @tryghost/members-csv (npm): affected all versions; fixed in 5.82.0
- @tryghost/members-csv (npm): affected all versions; fixed in 5.82.0
- ghost (Bitnami): affected all versions; fixed in 5.82.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34448/ (Markdown: https://insights.sbomify.com/CVE-2024-34448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34448
- OSV: https://osv.dev/vulnerability/CVE-2024-34448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34448/
Summaries are generated and may contain mistakes; the official description above is the record.
