# CVE-2024-34460: Zenario's Tree Explorer tool from Organizer affected by Cross-site Scripting

> Cross-site scripting in Zenario's Tree Explorer tool allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2024
- **Updated:** 15 Nov 2024
- **Also known as:** GHSA-7qwj-gcjf-828f

## What is CVE-2024-34460?

CVE-2024-34460 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Tree Explorer tool from Organizer in Zenario before 9.5.60602 is affected by XSS. (This component was removed in 9.5.60602.)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-34460?

2 open source packages ship an affected version, including tribalsystems/zenario.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tribalsystems/zenario` | Packagist | All versions | 9.5.60602 |
| `tribalsystems/zenario` | Packagist | All versions | 9.5.60602 |

## How do I fix CVE-2024-34460?

Upgrade tribalsystems/zenario to 9.5.60602 or later.

## Is CVE-2024-34460 being exploited?

There is no known exploitation of CVE-2024-34460 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34460 and fix it if it is affected.

What it is: CVE-2024-34460 is a medium-severity cross-site scripting vulnerability in n/a, published on 4 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34460 in the wild and no public exploit code.

Affected packages and fixed versions:
- tribalsystems/zenario (Packagist): affected all versions; fixed in 9.5.60602
- tribalsystems/zenario (Packagist): affected all versions; fixed in 9.5.60602

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34460/ (Markdown: https://insights.sbomify.com/CVE-2024-34460/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34460
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34460
- OSV: https://osv.dev/vulnerability/CVE-2024-34460

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34460/
Summaries are generated and may contain mistakes; the official description above is the record.
