# CVE-2024-34461: Zenario uses Twig filters insecurely in the Twig Snippet plugin

> A code injection vulnerability in Zenario CMS allows designers or administrators to execute arbitrary code via insecure Twig filters.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2024
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-hr2r-w6wc-25pv

## What is CVE-2024-34461?

CVE-2024-34461 is a critical code injection vulnerability in n/a, published on 4 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zenario before 9.5.60437 uses Twig filters insecurely in the Twig Snippet plugin, and in the site-wide HEAD and BODY elements, enabling code execution by a designer or an administrator.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-34461?

2 open source packages ship an affected version, including tribalsystems/zenario.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tribalsystems/zenario` | Packagist | All versions | 9.5.60437 |
| `tribalsystems/zenario` | Packagist | All versions | 9.5.60437 |

## How do I fix CVE-2024-34461?

Upgrade tribalsystems/zenario to 9.5.60437 or later.

## Is CVE-2024-34461 being exploited?

There is no known exploitation of CVE-2024-34461 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34461 and fix it if it is affected.

What it is: CVE-2024-34461 is a critical code injection vulnerability in n/a, published on 4 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34461 in the wild and no public exploit code.

Affected packages and fixed versions:
- tribalsystems/zenario (Packagist): affected all versions; fixed in 9.5.60437
- tribalsystems/zenario (Packagist): affected all versions; fixed in 9.5.60437

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34461/ (Markdown: https://insights.sbomify.com/CVE-2024-34461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34461
- OSV: https://osv.dev/vulnerability/CVE-2024-34461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34461/
Summaries are generated and may contain mistakes; the official description above is the record.
