{"answers":{"affected":"3 open source packages ship an affected version, including samwilson/unlinked-wikibase and mediawiki. It affects 2 products.","exploited":"There is no known exploitation of CVE-2024-34500 in the wild and no public exploit code.","fix":"Upgrade samwilson/unlinked-wikibase to 1.42.0 or later.","what":"CVE-2024-34500 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34500 and fix it if it is affected.\n\nWhat it is: CVE-2024-34500 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-34500 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- samwilson/unlinked-wikibase (Packagist): affected all versions; fixed in 1.42.0\n- samwilson/unlinked-wikibase (Packagist): affected all versions; fixed in 1.42.0\n- mediawiki (Bitnami): affected all versions; fixed in 1.41.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34500/ (Markdown: https://insights.sbomify.com/CVE-2024-34500/index.md)","id":"CVE-2024-34500","markdown":"https://insights.sbomify.com/CVE-2024-34500/index.md","name":"CVE-2024-34500","record":{"aliases":["BIT-mediawiki-2024-34500","GHSA-wcx3-63mm-h8x6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki extension","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via unescaped error messages in the UnlinkedWikibase extension, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the getError() function in the Hooks class.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MediaWiki UnlinkedWikibase Cross-site Scripting vulnerability","id":"CVE-2024-34500","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","mediawiki:mediawiki"],"type":"xss","year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2024-34502"},"packages":[{"ecosystem":"Bitnami","fixed":["1.41.1"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2024-34500"},{"ecosystem":"Packagist","fixed":["1.42.0"],"introduced":["0"],"last_affected":[],"package":"samwilson/unlinked-wikibase","purl":null,"source":"GHSA-wcx3-63mm-h8x6"},{"ecosystem":"Packagist","fixed":["1.42.0"],"introduced":["0"],"last_affected":[],"package":"samwilson/unlinked-wikibase","purl":"pkg:composer/samwilson/unlinked-wikibase","source":"GHSA-wcx3-63mm-h8x6"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2024-34490"},"products":["n/a"],"published":"2024-05-05","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via unescaped error messages in the UnlinkedWikibase extension, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2024-34500/"}