# CVE-2024-34506: Denial of service in n/a

> An attacker with move rights can cause a denial of service by requesting a page with many subpages, exhausting server resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2024
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-mediawiki-2024-34506, DEBIAN-CVE-2024-34506, DSA-5651-1, GHSA-v7x8-wrhv-8rh2, UBUNTU-CVE-2024-34506

## What is CVE-2024-34506?

CVE-2024-34506 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in includes/specials/SpecialMovePage.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. If a user with the necessary rights to move the page opens Special:MovePage for a page with tens of thousands of subpages, then the page will exceed the maximum request time, leading to a denial of service.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-34506?

1 open source package ship an affected version, including mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.41.1 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2024-34506?

Upgrade mediawiki to 1.41.1 or later.

## Is CVE-2024-34506 being exploited?

There is no known exploitation of CVE-2024-34506 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34506 and fix it if it is affected.

What it is: CVE-2024-34506 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34506 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34506/ (Markdown: https://insights.sbomify.com/CVE-2024-34506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34506
- OSV: https://osv.dev/vulnerability/CVE-2024-34506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34506/
Summaries are generated and may contain mistakes; the official description above is the record.
