{"answers":{"affected":"1 open source package ship an affected version, including mediawiki. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34507 exists.","fix":"Upgrade mediawiki to 1.41.1 or later.","what":"CVE-2024-34507 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-34507 and fix it if it is affected.\n\nWhat it is: CVE-2024-34507 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34507 exists.\n\nAffected packages and fixed versions:\n- mediawiki (Bitnami): affected all versions; fixed in 1.41.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-34507/ (Markdown: https://insights.sbomify.com/CVE-2024-34507/index.md)","id":"CVE-2024-34507","markdown":"https://insights.sbomify.com/CVE-2024-34507/index.md","name":"CVE-2024-34507","record":{"aliases":["BIT-mediawiki-2024-34507","DEBIAN-CVE-2024-34507","GHSA-gwp7-78vh-mpmm","UBUNTU-CVE-2024-34507"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki","requires_auth":"none","summary":"Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via mishandled escape characters in comments.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"mediawiki","vendor":"mediawiki"}],"cvss":{"score":7.4,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. XSS can occur because of mishandling of the 0x1b character, as demonstrated by Special:RecentChanges#%1b0000000.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2024-34507","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","mediawiki:mediawiki"],"type":"xss","year":"2024"},"n_packages":1,"n_references":2,"next":{"headline":"Null dereference in n/a","id":"CVE-2024-34508"},"packages":[{"ecosystem":"Bitnami","fixed":["1.41.1"],"introduced":["0"],"last_affected":[],"package":"mediawiki","purl":"pkg:bitnami/mediawiki","source":"BIT-mediawiki-2024-34507"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2024-34506"},"products":["n/a"],"published":"2024-05-05","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via mishandled escape characters in comments.","url":"https://insights.sbomify.com/CVE-2024-34507/"}