# CVE-2024-34507: Cross-site scripting in n/a

> Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via mishandled escape characters in comments.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 May 2024
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-mediawiki-2024-34507, DEBIAN-CVE-2024-34507, GHSA-gwp7-78vh-mpmm, UBUNTU-CVE-2024-34507

## What is CVE-2024-34507?

CVE-2024-34507 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki before 1.39.7, 1.40.x before 1.40.3, and 1.41.x before 1.41.1. XSS can occur because of mishandling of the 0x1b character, as demonstrated by Special:RecentChanges#%1b0000000.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2024-34507?

1 open source package ship an affected version, including mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.41.1 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2024-34507?

Upgrade mediawiki to 1.41.1 or later.

## Is CVE-2024-34507 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34507 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34507 and fix it if it is affected.

What it is: CVE-2024-34507 is a high-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 5 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34507 exists.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34507/ (Markdown: https://insights.sbomify.com/CVE-2024-34507/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34507
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34507
- OSV: https://osv.dev/vulnerability/CVE-2024-34507

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34507/
Summaries are generated and may contain mistakes; the official description above is the record.
