# CVE-2024-34515: image-optimizer allows PHAR deserialization

> Attackers can achieve code execution via PHAR deserialization in the image-optimizer library by exploiting the phar:// protocol in file existence checks.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2024
- **Updated:** 21 Aug 2024
- **Also known as:** CLSA-2026-1793215035, GHSA-6pjm-hmvf-h4rr

## What is CVE-2024-34515?

CVE-2024-34515 is a high-severity unsafe deserialization vulnerability in n/a, published on 5 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

image-optimizer before 1.7.3 allows PHAR deserialization, e.g., the phar:// protocol in arguments to file_exists().

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-34515?

2 open source packages ship an affected version, including spatie/image-optimizer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spatie/image-optimizer` | Packagist | All versions | 1.7.3 |
| `spatie/image-optimizer` | Packagist | All versions | 1.7.3 |

## How do I fix CVE-2024-34515?

Upgrade spatie/image-optimizer to 1.7.3 or later.

## Is CVE-2024-34515 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34515 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34515 and fix it if it is affected.

What it is: CVE-2024-34515 is a high-severity unsafe deserialization vulnerability in n/a, published on 5 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-34515 exists.

Affected packages and fixed versions:
- spatie/image-optimizer (Packagist): affected all versions; fixed in 1.7.3
- spatie/image-optimizer (Packagist): affected all versions; fixed in 1.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34515/ (Markdown: https://insights.sbomify.com/CVE-2024-34515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34515
- OSV: https://osv.dev/vulnerability/CVE-2024-34515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34515/
Summaries are generated and may contain mistakes; the official description above is the record.
