# CVE-2024-34517: Neo4j Cypher component mishandles IMMUTABLE privileges

> An attacker with admin access can escalate privileges due to mishandled IMMUTABLE privileges in the Cypher component.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2024
- **Updated:** 23 Jul 2025
- **Also known as:** BIT-neo4j-2024-34517, BIT-neo4j-enterprise-2024-34517, GHSA-p343-9qwp-pqxv

## What is CVE-2024-34517?

CVE-2024-34517 is a medium-severity vulnerability in Neo4j, published on 7 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The Cypher component in Neo4j 5.0.0 through 5.18 mishandles IMMUTABLE privileges in some situations where an attacker already has admin access.

Weakness: CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2024-34517?

4 open source packages ship an affected version, including org.neo4j:neo4j-cypher, neo4j and neo4j-enterprise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.neo4j:neo4j-cypher` | Maven | From 5.0.0 | 5.19.0 |
| `org.neo4j:neo4j-cypher` | Maven | From 5.0.0 | 5.19.0 |
| `neo4j` | Bitnami | From 5.0.0 | 5.20.0 |
| `neo4j-enterprise` | Bitnami | From 5.0.0 | 5.19.0 |

Products: Neo4j Neo4j.

## How do I fix CVE-2024-34517?

Upgrade org.neo4j:neo4j-cypher to 5.19.0 or later.

## Is CVE-2024-34517 being exploited?

There is no known exploitation of CVE-2024-34517 in the wild and no public exploit code.

## Other vulnerabilities in Neo4j

- [CVE-2021-34371](https://insights.sbomify.com/CVE-2021-34371/): Deserialization of Untrusted Data in Neo4j (critical 9.8)
- [CVE-2018-18389](https://insights.sbomify.com/CVE-2018-18389/): Incorrect access control in Neo4j Enterprise Database Server via LDAP authentication (critical 9.8)
- [CVE-2013-7259](https://insights.sbomify.com/CVE-2013-7259/): Neo4J vulnerable to Cross-Site Request Forgery (medium 6.8)
- [CVE-2026-14587](https://insights.sbomify.com/CVE-2026-14587/): Unathenticated connection can hold Bolt channel open (medium 5.5)
- [CVE-2026-1471](https://insights.sbomify.com/CVE-2026-1471/): Caching of authentication context (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34517 and fix it if it is affected.

What it is: CVE-2024-34517 is a medium-severity vulnerability in Neo4j, published on 7 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34517 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.neo4j:neo4j-cypher (Maven): affected from 5.0.0; fixed in 5.19.0
- org.neo4j:neo4j-cypher (Maven): affected from 5.0.0; fixed in 5.19.0
- neo4j (Bitnami): affected from 5.0.0; fixed in 5.20.0
- neo4j-enterprise (Bitnami): affected from 5.0.0; fixed in 5.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34517/ (Markdown: https://insights.sbomify.com/CVE-2024-34517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34517
- OSV: https://osv.dev/vulnerability/CVE-2024-34517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34517/
Summaries are generated and may contain mistakes; the official description above is the record.
