# CVE-2024-34528: WordOps has TOCTOU race condition

> A time-of-check time-of-use race condition in WordOps allows local attackers to escalate privileges or execute code via insecure file creation.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2024
- **Updated:** 1 Nov 2024
- **Also known as:** GHSA-23qq-p4gq-gc2g, PYSEC-2024-175

## What is CVE-2024-34528?

CVE-2024-34528 is a high-severity vulnerability in n/a, published on 5 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

WordOps through 3.20.0 has a wo/cli/plugins/stack_pref.py TOCTOU race condition because the conf_path os.open does not use a mode parameter during file creation.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2024-34528?

3 open source packages ship an affected version, including wordops.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordops` | PyPI | All versions | 3.21.0 |
| `wordops` | PyPI | All versions | 3.21.0 |
| `wordops` | PyPI | All versions | 3.21.3 |

## How do I fix CVE-2024-34528?

Upgrade wordops to a fixed version for your release line: 3.21.0 or 3.21.3.

## Is CVE-2024-34528 being exploited?

There is no known exploitation of CVE-2024-34528 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34528 and fix it if it is affected.

What it is: CVE-2024-34528 is a high-severity vulnerability in n/a, published on 5 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34528 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordops (PyPI): affected all versions; fixed in 3.21.0
- wordops (PyPI): affected all versions; fixed in 3.21.0
- wordops (PyPI): affected all versions; fixed in 3.21.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34528/ (Markdown: https://insights.sbomify.com/CVE-2024-34528/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34528
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34528
- OSV: https://osv.dev/vulnerability/CVE-2024-34528

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34528/
Summaries are generated and may contain mistakes; the official description above is the record.
