# CVE-2024-34535: Security feature bypass in n/a

> Attackers can bypass API rate limiting in Mastodon by sending crafted HTTP headers, potentially enabling abuse or denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2024
- **Updated:** 25 Nov 2024
- **Also known as:** BIT-mastodon-2024-34535, GHSA-f9c2-396j-6x9r, GHSA-q3rg-xx5v-4mxh

## What is CVE-2024-34535?

CVE-2024-34535 is a medium-severity vulnerability in n/a, published on 3 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Mastodon 4.1.6, API endpoint rate limiting can be bypassed by setting a crafted HTTP request header.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-34535?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | All versions | 4.2.9 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2024-34535?

Upgrade mastodon to 4.2.9 or later.

## Is CVE-2024-34535 being exploited?

There is no known exploitation of CVE-2024-34535 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-2166](https://insights.sbomify.com/CVE-2022-2166/): Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon (critical 9.8)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2024-23832](https://insights.sbomify.com/CVE-2024-23832/): Mastodon Remote user impersonation and takeover (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34535 and fix it if it is affected.

What it is: CVE-2024-34535 is a medium-severity vulnerability in n/a, published on 3 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34535 in the wild and no public exploit code.

Affected packages and fixed versions:
- mastodon (Bitnami): affected all versions; fixed in 4.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34535/ (Markdown: https://insights.sbomify.com/CVE-2024-34535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34535
- OSV: https://osv.dev/vulnerability/CVE-2024-34535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34535/
Summaries are generated and may contain mistakes; the official description above is the record.
