# CVE-2024-34537: Denial of Service in TYPO3 Bookmark Toolbar

> An administrator can cause a denial of service in the TYPO3 Bookmark Toolbar by manipulating saved data, requiring an upgrade to fix.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2024
- **Updated:** 31 Oct 2024
- **Also known as:** GHSA-ffcv-v6pw-qhrp

## What is CVE-2024-34537?

CVE-2024-34537 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 28 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

TYPO3 before 13.3.1 allows denial of service (interface error) in the Bookmark Toolbar (ext:backend), exploitable by an administrator-level backend user account via manipulated data saved in the bookmark toolbar of the backend user interface. The fixed versions are 10.4.46 ELTS, 11.5.40 LTS, 12.4.21 LTS, and 13.3.1.

## Which versions are affected by CVE-2024-34537?

8 open source packages ship an affected version, including typo3/cms-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-backend` | Packagist | From 10.0.0 | 10.4.46 |
| `typo3/cms-backend` | Packagist | From 10.0.0 | 10.4.46 |
| `typo3/cms-backend` | Packagist | From 11.0.0 | 11.5.40 |
| `typo3/cms-backend` | Packagist | From 11.0.0 | 11.5.40 |
| `typo3/cms-backend` | Packagist | From 12.0.0 | 12.4.21 |
| `typo3/cms-backend` | Packagist | From 12.0.0 | 12.4.21 |
| `typo3/cms-backend` | Packagist | From 13.0.0 | 13.3.1 |
| `typo3/cms-backend` | Packagist | From 13.0.0 | 13.3.1 |

Products: Typo3 Typo3.

## How do I fix CVE-2024-34537?

Upgrade typo3/cms-backend to a fixed version for your release line: 10.4.46, 11.5.40, 12.4.21 or 13.3.1.

## Is CVE-2024-34537 being exploited?

There is no known exploitation of CVE-2024-34537 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-34537 and fix it if it is affected.

What it is: CVE-2024-34537 is a medium-severity denial of service vulnerability in Typo3 Typo3, published on 28 Oct 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-34537 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-backend (Packagist): affected from 10.0.0; fixed in 10.4.46
- typo3/cms-backend (Packagist): affected from 10.0.0; fixed in 10.4.46
- typo3/cms-backend (Packagist): affected from 11.0.0; fixed in 11.5.40
- typo3/cms-backend (Packagist): affected from 11.0.0; fixed in 11.5.40
- typo3/cms-backend (Packagist): affected from 12.0.0; fixed in 12.4.21
- typo3/cms-backend (Packagist): affected from 12.0.0; fixed in 12.4.21
- typo3/cms-backend (Packagist): affected from 13.0.0; fixed in 13.3.1
- typo3/cms-backend (Packagist): affected from 13.0.0; fixed in 13.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-34537/ (Markdown: https://insights.sbomify.com/CVE-2024-34537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-34537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-34537
- OSV: https://osv.dev/vulnerability/CVE-2024-34537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-34537/
Summaries are generated and may contain mistakes; the official description above is the record.
