CVE-2024-34559 WordPress Ghost plugin <= 1.4.0 - Sensitive Data Exposure via Log File vulnerability

High 7.5 Published Updated

Attackers can access sensitive data exposed in log files within the Ghost CMS application, potentially compromising user privacy or system secrets.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-34559?

CVE-2024-34559 is a high-severity vulnerability in Ghost, published on 9 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Insertion of Sensitive Information into Log File vulnerability in Ghost Foundation Ghost.This issue affects Ghost: from n/a through 1.4.0.

Weakness: CWE-532

Which versions are affected by CVE-2024-34559?

1 open source package ship an affected version, including ghost.

PackageAffectedFixed in
ghost BitnamiAll versions1.5.0

How do I fix CVE-2024-34559?

Upgrade ghost to 1.5.0 or later.

Is CVE-2024-34559 being exploited?

There is no known exploitation of CVE-2024-34559 in the wild and no public exploit code.

Sources

Also known as BIT-ghost-2024-34559, GHSA-vhc5-hfx4-87r4.

Is CVE-2024-34559 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free